Comcast Sucks, Again. HD Rant Inside!

Since I got the netflix working on the XBOX I’ve been absolutely gay for high definition content. This is also the reason why I’m dropping comcast. Comcast, for all they employ and do for Philly, has the absolute worst pricing scheme and internet service. I’m saving almost half by going to Verizon.

Before my objections to comcast were largely intellectual. If you weren’t a geek, you probably wouldn’t care. Now that I’ve got this high-def set with enough resolution I can read the time off an ant’s wristwatch, I realize just how terrible it is. Objections to comcast for the common man follow:

The signal quality sucks: It does. Period. The end. I have tried every mode on my TV and two sets of connectors. Cartoons look like hell. I realize putting content designed for SD on a 1080p TV is going to look poor but spongebob is cubic enough without exposing the MPEG signal encoding. Anime nonwithstanding, cartoons are designed for an SD display and they should upscale gracefully without having blocks in the colors. Conversely just plugging the coax into my TV (digital tuner, FTW) I lose the cable guide but the cartoons and more importantly free high def content looks great.

No free high def content: Does your TV have a digital cable tuner? Try plugging it into the coax directly, if you’re a comcast person. You will get all the free, basic cable channels and the high def signals when it’s available. Why doesn’t comcast let you get to the high def programs freely over their cable box? Am I supposed to have a switch on the circuit which cuts between the raw coax and the comcast box? What the hell? What about alternate digital channels? Comcast lets you access “local content” but my TV found 70 something cable channels and 48 of them had alternate digital channels. There’s no presentation for this layer. (Actually there is, but digging the channel map to see that channel 12-4 is channel 835 while channel 12-3 is channel 521 is a bear).

On Demand is Fucking Useless: You would think that on-demand would substitute high def programs automatically. It doesn’t. Why are there two menu trees? Just do it like netflix and if it’s high def it’s “PRESENTED IN HD”, and if it’s low def it quietly sits in the corner. The worst part is that netflix over wifi looks better than comcast with a dedicated connection.

Their box is ugly: Their box is ugly and their remotes are too. I’ve seen better designed adult toys from degenerate cultures (canada) with more buttons.

The bandwidth issue: This is the worst. Comcast clamps the bandwidth after X amount of time. (If this is legal in your area). So you get 25mbps (mibi- not mega-) and then it throttles to 10mbps. Or whatever it is. If you weren’t bittorrenting, you didn’t notice it. If you were playing videogames, you wouldn’t notice it since you’ve had an AWESOME connection until you hit the cap. If you’re youtubing, you didn’t notice it. But consider the idea of streaming video (netflix). When I was watching Restrepo last night (great documentary), if I fired up the netflix and paused it immediately, the xbox would stream enough to the drive to display 1080p for a good amount of time. If I just let it fly, it would do about 15 minutes of 1080p and then clamp. But how does this effect the everyman? Quite simply if you watch youtube HD content or hulu or any of the other streaming TV services or even the brand new google TV, you’re going to get bit by it. Suddenly it’s not a geek issue about my videogame being slow or my bittorrent doing something weird, it’s a problem where you don’t get the best service you could possibly get and they want your eyes. I understand when you’re watching hulu you’re not giving them their advertising revenue, but the bandwidth issue is a direct attack against high def content delivered over the internet. This affects you, even if you’re using your laptop. Consider then if or when you get a high def TV, and you plug your laptop into it, you’re still not getting high def hulu.

The light didn’t go on before, but it’s on now.

“failed to retrieve account information”

If you’re getting “failed to retrieve account information” after getting a new android phone, or if you’re like me and getting it after you got your new Samsung Vibrant/Galaxy/Fascinate whatever back from the company after the update bricked it, then you’re not alone. I played with it quite a bit to try to figure out why the gallery could no longer post videos or photos. I did a bunch of factory resets and called TMobile. Finally I got down and dirty with the thing and figured it out.

Do a factory reset (only way to fix it, sorry), then if you have the update to at least Android 2.1.1, you’ll go back to your home screen and not the “sign in or sign up” screen. Let the media scanner run. Now the first thing you need to do before you do anything else
(including adding wifi configs or any other account) – click on market. You’ll be taken to the “sign up or sign in” screen. Choose sign in. You’ll add your google account per usual and market will close.

That’s it, this fixes your google account for posting videos and photos.